Forum FFL-ASL
ASL pour les nuls … et les autres !

VASL 4.1

Hors ligne Disrupt Michael

  • FFL-ASL Staff
  • 1-4-9
  • *
    • Messages: 1 761
    • +41/-12
  • Michel Bongiovanni
La nouvelle version de VASL (4.1) est dispo sur www.VASL.org depuis le 23 décembre 2003

Rodney Kinney a encore amélioré l'interface, notamment avec la prise en charge des terrains sur les cartes modifiées. Maintenant si vous placez un overlay d'OG sur une foret, le programme de LOS cessera de vous dire que celle-ci est bloquée par la foret supprimée. (Enfin en théorie, j'ai pas encore essayé).
Autre amélioration, si vous laissez le curseur au dessus d'une pile de pion sans cliquer, une fenetre apparait détaillant les plans de la pile.
On peut aussi regrouper toutes les fenetres en une seule, pour ne pas avoir un programme par fenetre dans la barre de taches.
Il y a surement d'autres choses.

Deux défauts toutefois:
1° L'installation est un peu bizarre.
2° Si vous ouvrez un fichier que vous avez créé avec une autre version, et que celui-ci contient des piles couvertes par un pion "?", vous obtenez une pile de "?" (comme lorsque vous regardez les "?" de votre adversaire) sans jamais pouvoir faire apparaitre les unités camouflées sous le pion.
Le seul remède que j'ai trouvé c'est de rouvrir le fichier avec une ancienne version (4.02), d'enlever les "?", de sauvegarder, de le rouvrir avec la version 4.1 et de remettre les pions "?". Là tout rentre dans l'ordre.


Hors ligne kubik

  • 8-1
  • *
    • Messages: 143
    • +1/-0
Salut,



Le probleme des conceal sur VASL4.1 se regle en remettant un conceal sur la "stack"...

Enfin pour moi ça marche.
"-On triche ou on ne triche pas, Anubis?
 -On triche, Bastet, on triche...          "


Robin

  • Invité
et la nouvelle version semble ne fonctionner que quand on est en ligne...
mais elle est plus agréable à utiliser...


Hors ligne Disrupt Michael

  • FFL-ASL Staff
  • 1-4-9
  • *
    • Messages: 1 761
    • +41/-12
  • Michel Bongiovanni
En fait, non , elle ne fonctionne pas qu'en ligne.

C'est ce que je voulais dire sur l'installation bizarre.
Vous allez sur VASL.org, aucune mise à jour n'est proposée, on peut seulement lancer VASL à partir du site.
Faire cela permet d'installer le programme et l'ouvre.
Lorsque vous le refermez, il n'y a aucun racourci ni dans le menu démarrer ni sur le bureau pour relancer le programme. Pour le relancer, il faut retourner sur le site vasl.org, cliquer à nouveau sur "launch VASL 4.1" et on vous propose alors de créer des raccourcis sur votre bureau et dans votre menu démarrer.
Il suffit d'accepter pour pouvoir ensuite utiliser le programme sans avoir recours au site web.

Ca fonctionne bien, mais je trouve ça un peu tordu. Le programme d'installation de la version 4.02 était plus compréhensible.


Hors ligne Disrupt Michael

  • FFL-ASL Staff
  • 1-4-9
  • *
    • Messages: 1 761
    • +41/-12
  • Michel Bongiovanni
Citation de: kubik
Salut,



Le probleme des conceal sur VASL4.1 se regle en remettant un conceal sur la "stack"...

Enfin pour moi ça marche.


Je ne comprends pas comment tu fais.
J'ai essayé de mettre un pion "?" sur un de mes tas de "?" (qui avec la version 4.02 est un stack 4-6-7 + HMG + ?, et devient avec la version 4.1 un gros tas de dummy), et au lieu d'avoir un stack de 3 "?", j'ai un stack de 4"?", mais il m'est toujours impossible de révéler mes troupes.
Bien, je dois mal m'y prendre car ça ne change que dalle.


Hors ligne slems

  • 7-0
  • *
    • Messages: 33
    • +0/-0
Citation de: Robin
et la nouvelle version semble ne fonctionner que quand on est en ligne...
mais elle est plus agréable à utiliser...


pour le lancer il faut exécuter le fichier "launch_module.jnlp" dans le répertoire vassal. il est possible d'en faire un raccourci n'importe où... :wink:


Robin

  • Invité
Je ne trouve pas ce fichier : est-ce que ça signifie que je doive télécharger un truc de plus?


Hors ligne slems

  • 7-0
  • *
    • Messages: 33
    • +0/-0
avec la version VASL 4.1 faut charger la version VASSAL Engine 1.3, et c'est là qu'il y aura le fichier "launch_module.jnlp".

faire une copie de ce fichier(pas un raccourci) le renommer "vasl.jnlp", puis l'éditer avec WordPad et suivre les indications qui y sont mentionnées.
(à savoir 2 lignes à corriger qui commence par ! EDIT :
remplacer <title>VASSAL</title> par <title>VASL</title>
et <argument>NAME_OF_MODULE_FILE</argument> par <argument>emplacement du fichier VASL.mod sur le DD</argument>)
ce nouveau fichier permet de lancer  directement VASL
ensuite créer un raccourci à placer où vous vouler, faire un clic droit sur le fichier du raccourci, la boite qui s'ouvre permet de voir les propriétés du fichier, et il est ainsi possible de sélectionner l'icone de VASL qui est télécharger en même temps que VASL  :shock:
c'est super non !!!!!!


Robin

  • Invité
j'ai installé Vassal, qui marche, mais y'a aucun fichier launch_module.jnlp...
Je dois être un peu "c*n"...  :roll:


Hors ligne François

  • 7+1
  • *
    • Messages: 20
    • +0/-0
Mais non, mais non... voici une procédure un peu plus simple

1/ clique sur ce lien :

http://www.java.com/en/index.jsp

2/ clique sur "Free Download" (dans le pavé vert en haut à droite)

cela va mettre à jour ta version de java

3/ reviens à VASL, page download, tu peux maintenant cliquer sur le lien

"Click here to launch the latest version of VASL" et tout doit se faire automatiquement.

François


Hors ligne Guillaume

  • Grognard en Maraude
  • 1-4-9
  • *
    • Messages: 5 439
    • +40/-0
Ben pour ma pomme, c encore pire!
Après avoir réussi à installer le nouvelle version de java une première fois, j'ai téléchargé VASSAL et VASL via java2.
Mais là, problème je me retrouve devant une fenêtre "planté" avec une autre fenêtre pour l'"agrement" de java2 (que j'avais pas validé jusque là, quel con!).
J'me dis "Pas grave, tu désinstalles le bazar et le réinstalle et youpla!". Mais depuis, impossible de mettre java2 que ce soit on line ou offline, l'installation plante au même endroit!
Je ne peux donc lancer VASL et VASSAL nouvelles versions!
Je vais réessayer un coup, sinon j'essaierais de voir si on peut me passer une "galette" avec les programmes!

Guillaume, Mired!
VotGCGIIIBattle Along the Riverbank
CGHatten
ToT4Stoumont: The Break-In
FrF21Cavalry Brigade Model
GD14They Fight Like Lions
SP196Hussars and Hounds
BFP133 Over the Hills
SP73 Seregelyes Slug-Out
FT213 Up the Liri Valley


Robin

  • Invité
On dit pas "mired".
En info, on parle de "bog(ue)"...
Mired alors!  :D


Hors ligne Guillaume

  • Grognard en Maraude
  • 1-4-9
  • *
    • Messages: 5 439
    • +40/-0
Ben, là, j'étais boggé au max et en pleine mired en fait!

D'ailleurs qu'elle la tracduction de Mired (D8.31) ? Je n'ai pas réussi à le trouver dans mon dico d'English!

Guillaume
VotGCGIIIBattle Along the Riverbank
CGHatten
ToT4Stoumont: The Break-In
FrF21Cavalry Brigade Model
GD14They Fight Like Lions
SP196Hussars and Hounds
BFP133 Over the Hills
SP73 Seregelyes Slug-Out
FT213 Up the Liri Valley


Robin

  • Invité
Ce sont des synonymes...
To be mired décrit un embourbement un peu plus intense que to be bogged (la différence entre un empêtrement dans la gadoue et un enfoncement jusqu'au moyeu).


Hors ligne Guillaume

  • Grognard en Maraude
  • 1-4-9
  • *
    • Messages: 5 439
    • +40/-0
Ah ben voilà! Ca faisait des lustres que je cherchais cette définition, bien que je m'en doutasse (?) quelque peu.
Sinon, pour revenir au sujet original, la version 4.1 est-elle compatible avec la 4.0.12, autrement dit 2 joueurs ayant chacun une version différente peuvent-ils jouer ensemble?

Guillaume
VotGCGIIIBattle Along the Riverbank
CGHatten
ToT4Stoumont: The Break-In
FrF21Cavalry Brigade Model
GD14They Fight Like Lions
SP196Hussars and Hounds
BFP133 Over the Hills
SP73 Seregelyes Slug-Out
FT213 Up the Liri Valley


Hors ligne Jean LL

  • 10-3
  • *
    • Messages: 895
    • +13/-1
Bonjour à tous,

J'essaie depuis plus d'une heure de mettre à jour ma version de VASL.
Je ne suis pas une bête en informatique mais là tout de même, ça devient franchement Ch###t !!!! :evil:

Qu'est-ce que c'est que ce bordel ? obligé de lancer le bazar depuis un site internet ??
Je n'arrive même pas à retrouver le programme dans l'arborescence de mon PC ! C'est peut être normal ?

L'installation de VASL a toujours été un peu compliquée (sauf l'avant dernière version) mais là franchement, je commence à en avoir marre !

Après avoir tant bien que mal réussi à lancer le bazar (après avoir lu les messages de ce forum, ceux laissés par les joueurs de VASL, etc.) j'arrive à installer cartes et pions (ouf !)

Mais v'là t'y pas que VASL plante carrément dès que j'essaie de me synchroniser sur un joueur pour voir une partie en cours : une fenêtre s'ouvre avec marqué "message" (que je n'arrive même pas à lire) et hop ! Rideau !

Vous l'avez compris, je suis à deux doigts de craquer : si vous avez la solution, ce serait vachement sympa de m'aider !

Merci d'avance
"Déjà vous n'êtes plus qu'un mot d'or sur nos places.
Déjà vous n'êtes plus que pour avoir péri"


Hors ligne Jeanfi

  • 10-3
  • *
    • Messages: 743
    • +20/-2
    • Cote 1664
As-tu installé la dernière version de java depuis le site sun ? j'avais un pb semblable avec une version précedente....
Essaye ca après avoir désinstallé la version précedente si elle n'est pas à jour...
bon courage  :wink:
Jeanfi :popov:


Hors ligne Jean LL

  • 10-3
  • *
    • Messages: 895
    • +13/-1
Java ! Je l'avais oublié celui-là !

Si je comprends bien la version sur mon micro est la j2re1.4.2_03

C'est la dernière ?
"Déjà vous n'êtes plus qu'un mot d'or sur nos places.
Déjà vous n'êtes plus que pour avoir péri"


Hors ligne Guillaume

  • Grognard en Maraude
  • 1-4-9
  • *
    • Messages: 5 439
    • +40/-0
c bien celle-ci, moi-même j'ai été incapable d'installer java!
J'attends une galette de la part de Manu, mais la POste est manifestement en grève :evil:

Guillaume
VotGCGIIIBattle Along the Riverbank
CGHatten
ToT4Stoumont: The Break-In
FrF21Cavalry Brigade Model
GD14They Fight Like Lions
SP196Hussars and Hounds
BFP133 Over the Hills
SP73 Seregelyes Slug-Out
FT213 Up the Liri Valley


Hors ligne Fred

  • 7-0
  • *
    • Messages: 38
    • +0/-0
Salut,
Effectivement il faut mettre à jour Java à partir du site de Sun. Une fois Java installé cliquer sur le download de VASL. VASL devrait à ce moment là se mettre à jour automatiquement.
Fred.
"L'intelligence, on croit toujours en avoir assez étant donné que c'est avec ça qu'on juge" - Coluche


Hors ligne Guillaume

  • Grognard en Maraude
  • 1-4-9
  • *
    • Messages: 5 439
    • +40/-0
Java n'est donc indispensable que pour l'installation?
Pour faire tourner VASL, on n'en a pas besoin?

Guillaume
VotGCGIIIBattle Along the Riverbank
CGHatten
ToT4Stoumont: The Break-In
FrF21Cavalry Brigade Model
GD14They Fight Like Lions
SP196Hussars and Hounds
BFP133 Over the Hills
SP73 Seregelyes Slug-Out
FT213 Up the Liri Valley


Hors ligne Fred

  • 7-0
  • *
    • Messages: 38
    • +0/-0
Non je pense que Java est nécéssaire pour faire tourner VASL, ne serait-ce pour gerer les LOS. Pour moi par exemple sur mon bureau après la mise à jour, j'ai un icone "Java web start" et l'icone VASL mais les deux ont le symbole de la "tasse à café" de Java. De plus depuis la mise à jour de la version 4.0 à la 4.1.1 quand je lance VASL, Java met à jour de lui même quelque fois, je suppose des librairies Java et il me semble VASL et VASSAL eux même automatiquement.

Fred.
"L'intelligence, on croit toujours en avoir assez étant donné que c'est avec ça qu'on juge" - Coluche


Hors ligne Guillaume

  • Grognard en Maraude
  • 1-4-9
  • *
    • Messages: 5 439
    • +40/-0
Ben j'ai viré ma dernière version de java et VASL 1.4.012 tourne bien, par contre je n'ai pas essayé on line seulement en PBEM.

Guillaume
VotGCGIIIBattle Along the Riverbank
CGHatten
ToT4Stoumont: The Break-In
FrF21Cavalry Brigade Model
GD14They Fight Like Lions
SP196Hussars and Hounds
BFP133 Over the Hills
SP73 Seregelyes Slug-Out
FT213 Up the Liri Valley


Hors ligne Dogan

  • Administrateur
  • 10-3
  • *
    • Messages: 849
    • +4/-0
    • http://www.cote1664.net
A mon avis si vous virer les library du java jre vous vous prédisposé à un certains nombre d'emmerdes avec VASL  :D
The only thing more accurate than incoming enemy fire is incoming friendly fire.


Hors ligne Guillaume

  • Grognard en Maraude
  • 1-4-9
  • *
    • Messages: 5 439
    • +40/-0
J'ai simplement viré le répertoire java dans le dossier Programs Files, je pense que d'autres fichiiers doivent encore traîné à droite à gauche et il me semble avoir vu les Library quelque part :?

Guillaume
VotGCGIIIBattle Along the Riverbank
CGHatten
ToT4Stoumont: The Break-In
FrF21Cavalry Brigade Model
GD14They Fight Like Lions
SP196Hussars and Hounds
BFP133 Over the Hills
SP73 Seregelyes Slug-Out
FT213 Up the Liri Valley


Hors ligne slems

  • 7-0
  • *
    • Messages: 33
    • +0/-0
java version j2re1.4.2_03
VASSAL 1.3.1.1
VASL 4.1.1

voilà, avec tout ça y a pas de blem ;)


Hors ligne Jean LL

  • 10-3
  • *
    • Messages: 895
    • +13/-1
... Je sens  que ça vient...

J'ai finalement réussi à installer Java puis on dirait que le reste s'est mis en place tout seul en cliquant sur un bouton sur le site de VASL...

Je m'voyais déjà... Et ben non, maintenant, j'ai un autre souci : ue fenêtre VASSAL s'ouvre et me propose gentiment quel jeu je veux pratiquer. Je clique sur VASL, une fenêtre VASL s'ouvre (vous savez, un coin de la carte 4) ... Et c'est tout. Ce petit coin de la carte 4 que nous connaissons si bien reste à l'écran (elle Freeze comme disent les initiés) et j'arrive même pas à la virer (sauf à passer par un bon vieux Ctrl-Alt-Suppr des familles...)

Oh, je me sens fatigué, moi...  :cry:
"Déjà vous n'êtes plus qu'un mot d'or sur nos places.
Déjà vous n'êtes plus que pour avoir péri"